Welcome to Our Community

Unlock hidden features. Sign Up for Free Today!

Dropping Z axis on E Stop

Discussion in 'CNC Mills/Routers' started by Dave Millard, Oct 30, 2016.

Tags:
  1. Dave Millard

    Builder

    Joined:
    May 26, 2014
    Messages:
    27
    Likes Received:
    0
    Hi everyone

    If I trigger either the E Stop or any limit switch, everything stops moving as it should but the Z Axis then sinks quite quickly under gravity allowing the still spinning bit to drive through the work piece.

    I would expect motion to stop and each axis to hold its position.

    I am using Mach3 to drive a chinese all in one board.

    Can this be configured differently either in the software, hardware or wiring?

    Would appreciate any input. Thanks.

    Dave
     
  2. Giarc

    Giarc Master
    Builder

    Joined:
    Jan 24, 2015
    Messages:
    254
    Likes Received:
    115
    I had a similar problem where my z would slowly lower when the machine was stopped. I use GRBL and there is a setting where you can set it to have power on to the motors at all time. That way when the z stops, it will hold the position. I am not sure what that setting is in Mach3, but in GRBL it solved my problem.
     
  3. Dave Millard

    Builder

    Joined:
    May 26, 2014
    Messages:
    27
    Likes Received:
    0
    Thanks. That is the answer I was hoping for. Anyone know where the setting in Mach3 is? Google is not my friend today.

    All the motors actually release so probably one switch would make them all hold. When I hit the soft limits, the motors hold so this is specific to E Stop and limit switches.
     
  4. Joe Santarsiero

    Joe Santarsiero OB addict
    Staff Member Moderator Builder

    Joined:
    Oct 30, 2014
    Messages:
    648
    Likes Received:
    135
    Hey Dave, I don't have anything in specific for you, but check ports and pins/output signals. There is a box to enable active high or low. I think if you change those the motors will hold for you during e-stop. It would be enable 1-4. Change the ones you want powered during estop. Try that and see what happens. I didn't have to change those setting with my Bob and drivers. They already hold during e-stop and give the option to set the current to 50% while holding inactive. This prevents them from getting hot. So this may be something you'll want to keep an eye on if you leave things in an e-stop state.
    A couple other avenues you might look into would be an axis brake that's active during e-stop or a counter force system to help neutralize weight of the spindle/router.
    Good Luck
    Joe.
     

Share This Page

  • About Us

    The OpenBuilds Team is dedicated helping you to Dream it - Build it - Share it! Collaborate on our forums and be sure to visit the Part Store for all your Building needs!
  • Like us on Facebook

  • Support Open Source FairShare Program!

    OpenBuilds FairShare Give Back Program provide resources to Open Source projects, developers and schools around the world. Invest in your future by helping others develop theirs!

    Donate to FairShare!