Welcome to Our Community

Some features disabled for guests. Register Today.

Ethernet ?

Discussion in 'Interfaces' started by MikieLikesIt, Dec 21, 2016.

  1. MikieLikesIt

    Builder

    Joined:
    Dec 28, 2014
    Messages:
    18
    Likes Received:
    0
    Hi , I've got a C25 smooth stepper board/ with Ethernet cable hooked up to my PC. Mach 3 and drivers are installed and seem to be working. The problem is when I hooked up my steppers and drivers, the arrow keys do not function. The PC seems to know there is a breakout board. I have uninstalled and reinstalled everything twice over and there is something I can't seem to figure out. I do have a parallel port on my PC, but figured the Ethernet would be better. Any suggestions please help, thanks.
     
  2. Joe Santarsiero

    Joe Santarsiero OB addict
    Staff Member Moderator Builder

    Joined:
    Oct 30, 2014
    Messages:
    800
    Likes Received:
    167
    Do you have the warp9 ess?
     
  3. MikieLikesIt

    Builder

    Joined:
    Dec 28, 2014
    Messages:
    18
    Likes Received:
    0
    Yes, I followed the instructions down the list
     
  4. MikieLikesIt

    Builder

    Joined:
    Dec 28, 2014
    Messages:
    18
    Likes Received:
    0
    I got to where it acknowledged the smooth stepper and break out board.
     
  5. Joe Santarsiero

    Joe Santarsiero OB addict
    Staff Member Moderator Builder

    Joined:
    Oct 30, 2014
    Messages:
    800
    Likes Received:
    167
    Does the position change on screen when you use the arrow keys? Have you set up mach3 or did you just plug everything in?
     
  6. MikieLikesIt

    Builder

    Joined:
    Dec 28, 2014
    Messages:
    18
    Likes Received:
    0
    nothing happens with the arrow keys. I've installed Mach 3. I went through Warp 9 and went down the list in the software section. I also did the ESS. At one point my PC recognized the smooth stepper, but now it does not indicate anything.I have 5volts to the board but not sure if the jumpers or jumper should be disconnected
     
  7. Joe Santarsiero

    Joe Santarsiero OB addict
    Staff Member Moderator Builder

    Joined:
    Oct 30, 2014
    Messages:
    800
    Likes Received:
    167
    Untitled 1
    Try following step 1 to setup Ethernet communication and see if that works.
     

Share This Page

  • About Us

    The OpenBuilds Team is dedicated helping you to Dream it - Build it - Share it! Collaborate on our forums and be sure to visit the Part Store for all your Building needs!
  • Like us on Facebook

  • Support Open Source FairShare Program!

    OpenBuilds FairShare Give Back Program provides resources to Open Source projects, developers and schools around the world. Invest in your future by helping others develop theirs!

    Donate to FairShare!