Welcome to Our Community

Unlock hidden features. Sign Up for Free Today!

Gcode sender problem

Discussion in 'Controller Boards' started by centurian, Mar 24, 2015.

  1. centurian

    centurian Well-Known
    Builder

    Joined:
    Dec 31, 2014
    Messages:
    28
    Likes Received:
    1
    As I'm building the OX I thought I'd stay true to Mark''s video tutorial as much as possible and went with the GRBL and the Arduino Uno. All was well with the setting up and connecting the power, everything lit up and I was able to add snippets of code into the Arduino interface and get the Nema's 17 and 23s to spin happily. Its quite something to see your handy work come alive and do what its supposed to do for a change.

    As I say, all went well until I set up the Universal Gcode sender. I tweaked it as directed by John from NYC CNC who's video got me this far.

    Anyway the Gcode Sender wouldn't work and I don't know why.

    Perhaps someone would have a look at the attachment and suggest a salution.

    Thanks. Ashampoo_Snap_2015.03.24_19h54m58s_001_.png
     
  2. David the swarfer

    David the swarfer OpenBuilds Team
    Staff Member Moderator Builder

    Joined:
    Aug 6, 2013
    Messages:
    521
    Likes Received:
    250
    hi
    assuming you are not running Linux or Mac then the message means that UGS cannot open the serial port because something else is using it.
    you did close Arduino IDE..... right? because that would prevent something else using the port.
    you did select the correct port and speed? if you open the hardware listing of ports you will see which one has the Arduino attached. if you always plug into the same USB socket, it should always come up as the same COM port.

    I find I have to plug it in before opening UGS otherwise it will never find the port.
     
  3. centurian

    centurian Well-Known
    Builder

    Joined:
    Dec 31, 2014
    Messages:
    28
    Likes Received:
    1
    Thanks fo0r the reply, but I've figured it out. As you say its a good idea to have everything plugged in before you try different software. In the case of the Gcode sender, I had it working up until I tried to turn the machine Control on. I didn't know you had to turn it on from the left. What an idiot.

    Also got the 'Y' Nema 23 to run in the opposite direction to its neighbour, so the gantry will now flow backwards and forwards without any problems.

    Thanks again.

    Michael.
     
  4. centurian

    centurian Well-Known
    Builder

    Joined:
    Dec 31, 2014
    Messages:
    28
    Likes Received:
    1
    Too much to hope for.
    I was sure I got this nailed and came back to running the Nima's this afternoon and now the 2 'Y' motors wont budge. Ive taken them off and ran each one seperately and they spin fine, so no major problems there.

    The uploaded photo shows the wire configuration for both 'Y'. I used the terminal block as its easier to re-arrange the wires, the screws are much bigger than the breakout board.

    I'm sorry, but the flash discoloured the wirring so heres the layout

    Perhaps someone can tell me how they wired these 2 motors up to run opposite to each other.

    Red
    Blue
    Black
    Green

    Going to the GRBL Board from the terminal block.



    SAM_0229.JPG


    Red & Red
    Blue & Blue
    Green & Black
    Green & Black

    Coming from the motors to the terminal block

    Thanks

    Michael
     
  5. David the swarfer

    David the swarfer OpenBuilds Team
    Staff Member Moderator Builder

    Joined:
    Aug 6, 2013
    Messages:
    521
    Likes Received:
    250
    check the green/black wires, you may have a green and black from the same motor onto one terminal instead of just inverted.

    I am going from the motor controller on the left to motors 1 and 2 on the right, so red1 is motor 1 and red2 is motor 2, etc

    red --------------red1 + red2
    blue -------------blue1 + blue2
    green ---------- green1 + black2
    black -------------black1 + green2

    to reverse a motor you only have to reverse one winding.
     
  6. centurian

    centurian Well-Known
    Builder

    Joined:
    Dec 31, 2014
    Messages:
    28
    Likes Received:
    1
    Hello David

    Thanks for your patience.

    All working as it should. Both the 'Y' Nema 23's going in the opposite direction to each other.

    Thanks a lot.

    Michael.
     

Share This Page

  • About Us

    The OpenBuilds Team is dedicated helping you to Dream it - Build it - Share it! Collaborate on our forums and be sure to visit the Part Store for all your Building needs!
  • Like us on Facebook

  • Support Open Source FairShare Program!

    OpenBuilds FairShare Give Back Program provide resources to Open Source projects, developers and schools around the world. Invest in your future by helping others develop theirs!

    Donate to FairShare!