Welcome to Our Community

Some features disabled for guests. Register Today.

GRBL homing fail

Discussion in 'Control Software' started by Brussel, Jul 8, 2017.

  1. Brussel

    Brussel New
    Builder

    Joined:
    Jun 25, 2015
    Messages:
    5
    Likes Received:
    0
    Hi All,
    probably my stupidity but I'm struggling to resolve a homing issue.

    I was having lots of false limit switch issues. I tried capacitors etc to no avail. I've now built an opto isolator board but have now run into problems. The only setting I've changed is the invert limit pins as the NC switches are now behind the opto isolator board.

    I connect to the arduino and I can manual trigger the limit switches no problems. I can also jog the machine with no issues. However I cannot get the machine to home. I get an ALARM:8 error. Also the Z axis also moves a small distance in the wrong direction as I home...strange.
     
  2. Brussel

    Brussel New
    Builder

    Joined:
    Jun 25, 2015
    Messages:
    5
    Likes Received:
    0
    doh....resolved it did NOT need the limit pins invert setting changed...
     

Share This Page

  • About Us

    The OpenBuilds Team is dedicated helping you to Dream it - Build it - Share it! Collaborate on our forums and be sure to visit the Part Store for all your Building needs!
  • Like us on Facebook

  • Support Open Source FairShare Program!

    OpenBuilds FairShare Give Back Program provides resources to Open Source projects, developers and schools around the world. Invest in your future by helping others develop theirs!

    Donate to FairShare!