Welcome to Our Community

Unlock hidden features. Sign Up for Free Today!

help with cnc x pro board

Discussion in 'CNC Mills/Routers' started by JON D, Apr 30, 2016.

  1. JON D

    JON D New
    Builder

    Joined:
    Apr 15, 2014
    Messages:
    12
    Likes Received:
    0
    i have the cnc x pro board and a laptop running windows 10. when i plug the board in it does not automaticly install anything. and when i open the grbl controller i can not select any ports. any help would be great as this is my first machine build.
     
  2. JON D

    JON D New
    Builder

    Joined:
    Apr 15, 2014
    Messages:
    12
    Likes Received:
    0
    Update I have got it to connect. Not sure how but it is. Now the issue is that when I jog the axis it tells me there's "undefined feed rate set" and the motor doesn't move but the numbers on the screen move. Any help?
     
  3. Daragh

    Daragh Well-Known
    Builder

    Joined:
    Dec 17, 2015
    Messages:
    2
    Likes Received:
    1
    Only new at this CNC lark but I had the same problem about a week ago, you need to give a feed rate command, try G1 x1 y1 f50 that should much the gantry a small bit on the x and y axis and you have set the feed rate at 50, if all goes well you can increase the speed higher. Grbl controller will move at the last f rate, you don't need to type f in the command again unless you are changing the feed rate.
     
    snokid likes this.

Share This Page

  • About Us

    The OpenBuilds Team is dedicated helping you to Dream it - Build it - Share it! Collaborate on our forums and be sure to visit the Part Store for all your Building needs!
  • Like us on Facebook

  • Support Open Source FairShare Program!

    OpenBuilds FairShare Give Back Program provide resources to Open Source projects, developers and schools around the world. Invest in your future by helping others develop theirs!

    Donate to FairShare!