Welcome to Our Community

Unlock hidden features. Sign Up for Free Today!

One axis louder than others

Discussion in 'CNC Mills/Routers' started by Rural, Feb 27, 2015.

  1. Rural

    Rural Journeyman
    Builder

    Joined:
    Aug 8, 2014
    Messages:
    42
    Likes Received:
    11
    So I've been working on a refurb of an old Routermaster II. I've replaced the original electronics with a TinyG and external CW-5045 drivers. Just powered it up this morning and started jogging around. Everything works wonderfully, but the X-axis is louder than the other axes. Turning the ball-screws for the X and Y axes, they feel about the same resistance-wise. I've started dropping the amperage to that motor, but it is well below the motors 4.67A rating. I'm about to swap two of the drivers to try to eliminate the driver as the culprit.

    Any other ideas as to what might be the cause?
     
  2. Rural

    Rural Journeyman
    Builder

    Joined:
    Aug 8, 2014
    Messages:
    42
    Likes Received:
    11
    Swapping the X and Y drivers produced the same result. I should add that this isn't just a slight difference. When the X-axis moves, I am near cringing. It might just be something resonating with the motor. Not sure. In any case, I'm going to pretend that everything is fine for the moment and dial in the velocity and acceleration.
     
  3. Rural

    Rural Journeyman
    Builder

    Joined:
    Aug 8, 2014
    Messages:
    42
    Likes Received:
    11
    As soon as I raised the maximum velocity and did a jog, it became clear that the noise was due to something resonating with the motor. From 4 to 12 inches/minute, cacophony resulted. Over 12 inches/minute, all was well.

    We might run our first job this afternoon. I'm pretty excited to see some wood-chips fly.
     
  4. GrayUK

    GrayUK Master
    Staff Member Moderator Builder

    Joined:
    May 5, 2014
    Messages:
    923
    Likes Received:
    214
    Rural
    I say this guardedly, and please read up to confirm this statement, but generally, a noisy motor is a sign of low amps.

    Gray
     
  5. Rural

    Rural Journeyman
    Builder

    Joined:
    Aug 8, 2014
    Messages:
    42
    Likes Received:
    11
    Thanks Gray. I did some more testing in the afternoon and ran an air job. It was definitely something resonating in the gantry, a long way from the X-axis' motor. I tried to track it down, but couldn't find anything loose. Certainly, the motor isn't missing steps or anything like that.

    Once it was running jobs, the owner came over and had a look. After a moment, he stated that it was running exactly as he remembered (except for being half speed). Doubled the speed and he gave me the thumbs up.

    Unfortunately, the program he used to generate his G-code (TPCWin, which is pretty ancient) seems to do something strange that Chilipeppr doesn't like. Of the couple of jobs we've tried, neither were quite right. One was for a circular saw blade (cut out of wood), and it was missing a few teeth. Not a big deal as he was in the process of converting to VCarve anyway. On Monday, we should be putting the thing through its paces.
     
  6. GrayUK

    GrayUK Master
    Staff Member Moderator Builder

    Joined:
    May 5, 2014
    Messages:
    923
    Likes Received:
    214
    I'll wait to hear from you, and how it went.

    Gray
     

Share This Page

  • About Us

    The OpenBuilds Team is dedicated helping you to Dream it - Build it - Share it! Collaborate on our forums and be sure to visit the Part Store for all your Building needs!
  • Like us on Facebook

  • Support Open Source FairShare Program!

    OpenBuilds FairShare Give Back Program provide resources to Open Source projects, developers and schools around the world. Invest in your future by helping others develop theirs!

    Donate to FairShare!