Welcome to Our Community

Unlock hidden features. Sign Up for Free Today!

Site is very, very slow

Discussion in 'OpenBuilds Forum Help' started by Zootalaws, Nov 18, 2014.

  1. Zootalaws

    Zootalaws Veteran
    Builder

    Joined:
    Aug 4, 2014
    Messages:
    105
    Likes Received:
    18
    I don't think it is me... I ran a number of web tests from US, Australasia, Asia, Europe and all of them came back with load times greater than 10 secs/page. This means that often the web software times out and just returns the front page, not the page you linked to.

    While Xenforo is really pretty, it also has a huge number of instances of people going : "Site is really slow".

    Have you had anyone look at your installed options, your cacheing, your PHP and SQL config?

    It has gotten to the stage that, while I would love to contribute to the forum, I am sick of spending half an hour to do something that should take 3-4 minutes.

    You can forget things like loading updated pictures, the system even struggles to refresh the alert list at the top right. I have learned through bitter experience to copy my post before pressing 'submit' - too many times have I done so only to lose the whole thread.

    It's almost like you are running on $1 a month shared hosting, it's that bad...

    (While I was writing this, something that is relatively trivial on most forum apps, I got the dreaded 'red screen of death' - where Javascript just gives up.)
     
  2. Zootalaws

    Zootalaws Veteran
    Builder

    Joined:
    Aug 4, 2014
    Messages:
    105
    Likes Received:
    18
    And... after submitting, the site timed out and dumped me back to the main openbuilds.com home page.

    Normally I wouldn't bother, but it's so bad it really must be hurting your business.
     
  3. Zootalaws

    Zootalaws Veteran
    Builder

    Joined:
    Aug 4, 2014
    Messages:
    105
    Likes Received:
    18
    The time between the first post and the second is how long it took to reload and get back to the point you could re-enter another message. nearly 19 minutes of frustration.
     
  4. dddman

    dddman Master
    Builder

    Joined:
    Mar 2, 2014
    Messages:
    433
    Likes Received:
    152
    Sometimes on Firefox the website is redirecting me to the main page, logged off, and there is no way to login again. But when it does that, I just login with Chrome and all's fine, and some time later the page works again on Firefox... but the website is never slow with me...
     
  5. JustinTime

    JustinTime Master
    Builder

    Joined:
    Dec 18, 2013
    Messages:
    771
    Likes Received:
    152
    I didn't try Firefox, like dddman did, I use only Chrome. When I was in Canada, the place I stayed had problem with the wifi. There, I timed out many times. Now I'm back in SoCal, with the same computer and the same setup, and I have no timeouts. Mi wifi is very good. My point is, Zootalaws, that maybe the problem you are seeing is your internet connection.
     
  6. Zootalaws

    Zootalaws Veteran
    Builder

    Joined:
    Aug 4, 2014
    Messages:
    105
    Likes Received:
    18
    If 5mb/sec isn't enough, then maybe it's a problem.

    But, I don't have this problem with any of the more than 20 forums I frequent, nor do I have a problem with open build parts store.

    FWIW, I've been a Comms specialist since around 1975, been active on the Internet since the mid 80s and worked developing wifi systems before it was 802.anything.

    It's not my internet connection.
     
  7. dddman

    dddman Master
    Builder

    Joined:
    Mar 2, 2014
    Messages:
    433
    Likes Received:
    152
    Did you try to reset your router? :p Just kidding ;)
     
  8. Mark Carew

    Mark Carew OpenBuilds Team
    Staff Member Resident Builder Builder

    Joined:
    Jun 28, 2013
    Messages:
    1,822
    Likes Received:
    927
    We are running on a dedicated server now, all should be good.
    Thanks for the feedback
    Mark
     
  9. Joe Santarsiero

    Joe Santarsiero OB addict
    Staff Member Moderator Builder

    Joined:
    Oct 30, 2014
    Messages:
    648
    Likes Received:
    135
    I've never had a problem with the site. Android mobile and Firefox.
     
    Mark Carew likes this.

Share This Page

  • About Us

    The OpenBuilds Team is dedicated helping you to Dream it - Build it - Share it! Collaborate on our forums and be sure to visit the Part Store for all your Building needs!
  • Like us on Facebook

  • Support Open Source FairShare Program!

    OpenBuilds FairShare Give Back Program provide resources to Open Source projects, developers and schools around the world. Invest in your future by helping others develop theirs!

    Donate to FairShare!