Welcome to Our Community

Unlock hidden features. Sign Up for Free Today!

SketchUCam Gcode Joining Feature Does not work for me.

Discussion in 'CAM' started by n0kjf, Oct 26, 2015.

  1. n0kjf

    n0kjf Well-Known
    Builder

    Joined:
    Feb 10, 2014
    Messages:
    18
    Likes Received:
    3
    I seem to be doing something wrong white attempting to join 2-4 Gcode files. I push Join button, add the 2 files I wish to join. The join feature is waiting for me to add more files, or cancel. If I cancel I get prompted to enter a new file name for the joined files. I get no confirmation, even after waiting overnight, the "new" file ends up 0 KB in size. Am I missing something?

    I have read though the help and I think I am following the help notes to a "T". I did not find any forum addressing this question.
     
  2. David the swarfer

    David the swarfer OpenBuilds Team
    Staff Member Moderator Builder

    Joined:
    Aug 6, 2013
    Messages:
    521
    Likes Received:
    250
    Hi Lew
    Are the files you are joining created from SketchUcam?

    The joiner looks for the starting line
    G90 G21 G49 G61 G17 (really only needs the G90)
    and the ending lines (any one of)
    G00 X0 Y0 (home)
    M30
    so if your files do not have those lines they will not join properly.

    It excludes all lines before the G90, and includes the G90 line.
    It excludes the G0 x0 y0 line except on the last file, same with the M05 line since there is no need to stop the spindle between files.

    Please post your problem files here for me to look at, there may well be a bug I need to stomp on (-:

    You can watch me using the joiner in this video...
     
    n0kjf likes this.
  3. n0kjf

    n0kjf Well-Known
    Builder

    Joined:
    Feb 10, 2014
    Messages:
    18
    Likes Received:
    3
    All files were created on SketchUCam V1.3a which is, I believe the latest version. I've attached the Gcode and the original files. Thanks for the prompt reply and off of assistance.

    Lew Heifner
     
  4. David the swarfer

    David the swarfer OpenBuilds Team
    Staff Member Moderator Builder

    Joined:
    Aug 6, 2013
    Messages:
    521
    Likes Received:
    250
    quite interesting....
    your filename on your 'D' file is very long, long enough to trigger a function to split it into smaller pieces to keep GRBL happy (it has a 70 or 80 character line length limit).
    However, that function is failing!

    So, shorten that files name to not longer than the A B and C files and it will join just fine.
    OR
    set 'Use Comments' to false in Tools|Phlatboyz|Options|Machine Options which will prevent the joiner form trying to create the long comment from the filename in the first place.
     
    n0kjf likes this.
  5. n0kjf

    n0kjf Well-Known
    Builder

    Joined:
    Feb 10, 2014
    Messages:
    18
    Likes Received:
    3
    That works, Thanks you very much. I like to put a bunch if info in the file name so when I get to the router, I know what it is supposed to do.

    Now I just need to clean up cut C so it does not have the segment errors again.
     

Share This Page

  • About Us

    The OpenBuilds Team is dedicated helping you to Dream it - Build it - Share it! Collaborate on our forums and be sure to visit the Part Store for all your Building needs!
  • Like us on Facebook

  • Support Open Source FairShare Program!

    OpenBuilds FairShare Give Back Program provide resources to Open Source projects, developers and schools around the world. Invest in your future by helping others develop theirs!

    Donate to FairShare!