Welcome to Our Community

Unlock hidden features. Sign Up for Free Today!

Using a laptop? Want to? Parallel under-powered?

Discussion in 'Helpful Tools' started by scottyd, May 16, 2016.

  1. scottyd

    scottyd Well-Known
    Builder

    Joined:
    Apr 14, 2016
    Messages:
    24
    Likes Received:
    5
    Something recently that I have ran into was that I tried to use a laptop to setup my latest build. I currently have my build inside of my house (instead of my shop) So I have been using an old Toshiba Workbook to help me get the machine situated... Beats dragging all of the old dusty shop PC stuff indoors.

    The Laptop would not send accurate pulses to my Gecko g250 to save its life. I did some research and found that this is a common problem with UNDER powered Parallel Cards... Seemed odd to me so under more research I found that it's not uncommon at all that a simple software (driver) change could fix it. The card or the laptop was not under-powered, the software that controls the power was!

    Most laptops are setup as ACPI (some desktops even!) That stands for Advances Configuration and Power Interface when its enabled it lets windows control many power features. I assume many of these are throttled down to help with battery consumption/demand. In simple terms. ACPI screws up parallel port output and makes it very erratic ACPI is the Devil of CNC'n.

    This is what I did on my XP Toshiba... Go to device manager, at the top of the list is a little computer icon that says you guessed it, Computer... Click the + sign beside that icon, it will drop down a menu, if its a lap top or notebook, it will likely say "ACPI" right click on that, select update driver, don't do a search, pick let me choose driver, when it give you the list choose "standard pc" from that list and install that. It should install and your machine will ask to re-boot, close all of your Open Builds forum thread windows and reboot that bad boy...

    After re-boot, your machine will basically have to find and reinstall most every hardware driver it has. Mine did so automatically, I just had to sit and press "ok" like a thousand times.. no biggie. Once all the drivers are reinstalled again you'll need to reboot again. After the reboot all should look normal on your machine visually, try out your parallel port, and if its like mine it will work flawlessly, it is no longer under
    powered..

    NOW, the only bad side of this that I found is, now your machine has lost most of its power management options IE sleep, hibernate ect..There may be a way to get them back.. IDK I have not taken the time to look.. The battery will not last long, your lappy is now running on all 8 top fuel cylinders.. it's no biggie for me, I leave mine plugged in and when I'm done using it, I just shut it down.
    Hope that helps!
     
  2. AR15DCM

    AR15DCM Journeyman
    Builder

    Joined:
    Dec 10, 2015
    Messages:
    60
    Likes Received:
    9
    Have you tried to just create a new power management plan where nothing shuts off? Create a new plan and make sure you go into advanced... you see a whole lot of power management settings which may solve the problem without changing your driver. When you want to use the laptop for CNC just change the power plan.

    You can see the Advanced Power settings in the bottom screenshot.

    power plan.png



    power plan advanced.png
     

Share This Page

  • About Us

    The OpenBuilds Team is dedicated helping you to Dream it - Build it - Share it! Collaborate on our forums and be sure to visit the Part Store for all your Building needs!
  • Like us on Facebook

  • Support Open Source FairShare Program!

    OpenBuilds FairShare Give Back Program provide resources to Open Source projects, developers and schools around the world. Invest in your future by helping others develop theirs!

    Donate to FairShare!